Python 3.3 ImportError: DLL load Failed: The specifiied module could not be found

There is a similar thread with a similar title from about a year ago, but I have this issue and have not found the solution despite the previous thread. I’m using
Python 3.3.2 (v3.3.2:d047928ae3f6, May 16 2013, 00:06:53) [MSC v.1600 64 bit (AMD64)] on win32, Windows 7 Ultimate SP1, using the Python files from FrontPanel-USB 4.2.5. I copied the recommended files to the same directory as my .py files.

I get the following error when I start up:
Traceback (most recent call last):
File “C:\Users\avestruz\Dropbox\Wireless Power\Python\PythonVer4\”, line 101, in
import controllers
File “C:\Users\avestruz\Dropbox\Wireless Power\Python\PythonVer4\”, line 5, in
import ok
File “C:\Users\avestruz\Dropbox\Wireless Power\Python\PythonVer4\”, line 26, in
_ok = swig_import_helper()
File “C:\Users\avestruz\Dropbox\Wireless Power\Python\PythonVer4\”, line 22, in swig_import_helper
_mod = imp.load_module(’_ok’, fp, pathname, description)
File “C:\Python33\lib\”, line 183, in load_module
return load_dynamic(name, filename, file)
ImportError: DLL load failed: The specified module could not be found.

Has anyone else had the same error and perhaps a solution?


My colleague tried to use python API and got the similar issue on a windows 7 64bit machine with python 2.7 (32bit).

I searched a lot and finally fixed this problem by installing “Visual C++ Redistributable Packages for Visual Studio 2013”.

Here’s the link of this Microsoft vistual studio redsitributable package

There are two versions: one is 32bit, one is 64bit.

I’m using python2.7 32bit, so I installed the 32bit one and now “import ok” works.

I also installed the 64bit redistribute package as the Frontpanel GUI application needs it, otherwise it complains “msvcp120.dll missing…”.

Although this thread is one year old, I hope this solution can help somebody.