Xilinx ISE Simulation Error

Good Afternoon,

I am a new user of XEM6001 and as I’m trying just to compile and simulate the Counters example from the installation CD.

As I followed the ReadMe file, I still have an error when I try to simulate the project:

ERROR:Simulator:745 - No architecture found for entity okcore_default

In my project I have added 3 files to the project:


And others .vhd files have been copied in the project folder.
Am I missing something?


Please refer to our FrontPanel User’s Manual regarding simulation.

Thank you for replying, I read the FrontPanel User’s Manual and I don’t see how to execute the first_isim.bat file from ISE…

I have tried to create a new project including source files, but it brings me back to the previous error.


You don’t execute BAT files from ISE. You execute them from a command line.


I run the bat file for the example FIRST from the installation CD and it seems like the communication is not working, the result is always zero

                    r1 := r1 + x"1111";
		r2 := r2 + x"2222";		
		exp := r1 + r2;
		SetWireInValue(x"01", r1, x"ffff");		
		SetWireInValue(x"02", r2, x"ffff");		
                    sum := GetWireOutValue(x"21");

The value in SUM doesn’t change at all. I have tried to compile and run the same example using Cadence and it worked, how can I fix this problem?
The response delay looks different comparing both softwares.

Thank you