XEM3005 FPGA configuration failed

Hi there,
I tried to load FPGA bit to XEM3005 through the FrontPanel ver. 4.0.3, and it was always unsuccessful with error message:

FPGA configuration failed:Done did not go hight

Now, the JP2 is in position USB config. The board is successfully detected and correctly recognized by the FrontPanel.

I have tried to load files:
which I have found in the FrontPanel directory
and tutorial.bit from Xilinx.

The result was always the same error.

What could be the possible reason for that?

Thanks in advance!

Are you using the BRK3005 to power the board?

I am getting the same error: “FPGA configuration failed: Done did not go high” when I try to configure my XEM5010 board. I am using FrontPanel 3.1.5 and have tried configuring the board with First-xem5010.bit but get this error consistently. I installed different versions of the software and have installed the software on a different computer, and have tried changing different FrontPanel preferences still get the same error every time.

Could this be a faulty board? Please help!


Just wonder if someone can help me solve the problem.

I use the flashloader.exe from opal kelly driver 4.0.8.
It does not come with the flashload-xem3005-1200.bit, so I copied one from a previous version.

When I run the flashloader, it always reports that the FPGA cannot be initialized.
I can access the FPGA using Frontpanel and write in the bit file directly into FPGA.
The JP2 is set to USB Config during flash loading.
Frontpanel is turned off when I try the flash loading.

Here is the repot.
C:\Program Files\Opal Kelly\FrontPanelUSB\Samples\FlashLoader>flashloader Counters-xem3005-12000.bit
---- Opal Kelly ---- SPI Flash Programmer ----
FrontPanel DLL loaded. Built: Feb 1 2012 16:56:12
Device firmware version: 3.1
Device serial number: GueEwLqzgW
Device device ID: Opal Kelly XEM3005
FPGA configuration failed.
FPGA could not be initialized.

Here are the files in the same directory.
06/17/2009 08:32 PM 254,140 Counters-xem3005-1200.bit
06/17/2009 08:48 PM 424,932 flashload-xem3005-1200.bit
02/01/2012 06:03 PM 160,768 flashloader.exe
02/01/2012 05:56 PM 83,968 okFrontPanel.dll
12/20/2010 01:14 PM 1,345 README.txt
04/11/2012 03:58 PM 480,246 sar_ctrl_s2p.bit

Get the latest files here:


If you look at the C++ sources, you’ll see that it’s actually looking for a file called “flashloader.bit”.

After I copied the flashload.bit to the folder, it just worked.
Thanks for your help.

I suggest OK to update the README file in /sample/flashloader.
Then people don’t need to come to the forum for help.

Thanks for pointing that out. We fixed the README to refer to flashload.bit and it will make it into the next release.