URGENT: Block Throttled Pipe Reads/Writes not functioning

Hi,

We have the following board:

Base Product: XEM6310-LX150
2014-06-06 16:52
Firmware 1.16
Firmware ID: 20131217-XS6-1.16

and using:

FrontPanel 4.4.1

It is very critical for us to be able to use “Throttled Block Read” feature at the specified performance levels. We haven’t been able to get Throttled Block Reads work properly so far even after going through the ticketing mechanism of Opal Kelly Support. And, yes, we have tried different USB 3.0 cables on different computers and on different OS’s and the result is same.

In Python we execute the following:

import ok
dev = ok.okCFrontPanel()
dev.OpenBySerial("")
0

dev.IsFrontPanelEnabled()
True

dev.IsHighSpeed()
False

dev.IsFrontPanel3Supported()
False

As you can see, "IsFrontPanel3Supported’ returns “False” for some reason. We would like to be able to use the following methods which are supposed to be enabled only if Front Panel 3 support is enabled according to the documentation:

ReadFromBlockPipeOut()
WriteToBlockPipeIn()

These methods function as if they are not Block Throttled and the FIFO cannot can not handle the data, fills up and empties even before the specified data block is read. We tried with different read block sizes all the way from 16 to 16384 with no success.

And, as a side note, when we execute IsFrontPanel3Supported on a 6010 board on exactly the same system, it returns “True”. This tells us that we can use block throttled reads on a 6010 but not on a 6310 board.

We need an urgent solution for this problem and any help to debug this issue is greatly appreciated.

Cheers,

Umut

Hi Umut,
Were you able to solve this issue?
I am interested in the solution.
regards,
Johan

It is fixed Johan. We had to play with the FIFO parameters.