Trying to control XEM3001, but glitching in labview


I am trying to control the XEM3001. I imported the .dll libraries into labview, as suggested, and they largely work - I can ask the fpga for its model number and so on. Unfortunately, when I run my code, it works fine the first time, opening the connection and downloading the .bit file (which is all its supposed to do), but if I try to re-run it (say, with a different .bit file), it does not work - the number of OK devices is measured to be zero and so on. The only way to get it back is to manually unplug and reconnect the fpga.

I have narrowed the problem step to the call of “OpenBySerial”. How can I fix this?


You need to make sure your LabView code properly “destroys” the okFrontPanel instance. Otherwise, the object remains allocated and you cannot open it until it becomes available again.

Just make sure that LabView properly calls the destroy method prior to terminating the program.

That worked!

How can you do that? Please explain, how can you configure your program in LABView and LABView software.