Pipetest wont load DLL

Im using Visual Studio 2010, and when I run my compiled version of Pipetest, it wont load the DLL referenced on the 1st line in main function.

printf("---- Opal Kelly ---- PipeTest Application v1.0 ----\n");
if (FALSE == okFrontPanelDLL_LoadLib(NULL)) {
	printf("FrontPanel DLL could not be loaded.\n");

I have the DLL " file okFrontPanell.dll" in the directory where I run the executable, and also made sure when I compiled, I used the suggested setting for the C++ compiler, Code Generation --> Runtime Library --> Multi-threaded Debug DLL (/MDd)"

WHen I run the executable, it always fails at this line. WHen I run the executable provided on the install disk from Opal-Kelly (pipetest.exe) it works fine in the same directory.

can anyone tell me what might be going wrong?



Please make sure the architecture of the DLL matches the architecture of your executable, per the instructions in the FrontPanel User’s Manual. In other words, 32-bit DLL + 32-bit executable. 64-bit DLL + 64-bit executable.

This was due to my using the wrong DLL, i.e. there are separate DLLs for 32 bit and 64 bit.