My XEM-3010 is not working

Hello,

I got my new XEM3010 2 days ago, I have some questions:

  1. What is U10 … it 's not installed on my board !!

  2. I followed all the instructions and downloaded the demo first-xem3010-1000.bit and got the “FPGA config. complete” message and then I loaded the first.xfp panel but none of the LEDs would turn on … also the panel won’t read the status of the switches. Any ideas what could be going worng?

  3. I tried to program the PLL … I started the PLL config panel and perfomed EEPROM READ but nothing happen the panel sits there … no messages or anyting I tried EEPROM WRITE same thing … Is there a guide somewhre about how this thing actually works?

  4. How can I get a pdf file of the XEM3010 schematics to help me debug the board when it’s not working ?

@yassermi-

  1. U10 is the Xilinx Platform Flash. My guess is that you ordered the XEM3010-1000 which does not have the PROM installed.

  2. Hm. I’ll look into this. Have you tried the other samples yet?

  3. Have you looked at the FrontPanel User’s Manual? There is a brief section of the PLL configuration dialog. It was specifically written for the PLL on the XEM3001 and XEM3005, but very similar buttons exist on the PLL dialog for the XEM3010.

  4. We do not provide schematics for the XEM3010.

Thanks for the quick reply …

  1. what is the complete P/N of U10 so I can order it and install it on the board.

  2. Yes, I tried other sample code … The counters demo flashes the LEDs so I know they work … they just don’t work with the “First” demo project.

  3. The user manual helps for PLL config. thanks.

  4. New problem: I tried to run RAMTest.exe from the DOS screen … (I’ve already renamed the bitfile to ramtest.bit) … I got back the following messages:
    Found a device: XEM3010
    Device firmware version: 1.4
    Device serial number: UgnRzAtmGH
    Device ID string: Opal Kelly XEM3010
    FrontPanel support is not enabled. :mad:
    FPGA could not be initialized. :mad:
    Any ideas!! :confused:

Please email support@opalkelly.com and we can walk you through a few things. It looks like you may have received a board with the older firmware on it by accident.