FPGADES fails to contact the XEM


#1

Hi Jake :),

I’m going through the tutorials, and I got a strange thing in the third part. I’m able to contact the XEM and run all the examples but if I run the FPGADES.exe it says:

---- Opal Kelly ---- FPGA-DES Application v1.0 ----
XEM could not be opened. Is one connected?
FPGA could not be initialized.

I obtain the same result if I start the program from .NET. The environment says that all DLL are perfectly in place and loaded. The program seems to fail during the “xem->Open(0);”. Any thought?

Thank you!

PS: I have just discovered that “destester.exe” works fine. What am I doing wrong?


#2

Hi santini-

It looks like we need to updat the tutorial project. Part 3 apparently didn’t get updated for the v2 boards. It is looking for a v1 board and can’t find it.

We’ll get this fixed and post new project files shortly. Thanks for reporting this!


#3

I should also note that the tutorial’s part 3 is pretty much the same as the DESTester. DESTester was added as part of the samples after the tutorial had been written.


#4

I just checked the source code… and yes… the part 3 refers to the version 1 :). I changed the code according to the version 2 of the library and everything seems to be fine :smiley: .

Thanks!