Driver problems

Sometimes when I connect my FPGA to the usb, windows won’t recognize the driver, and will ask me to search and install it again. This is totally random, because sometimes I plug the FPGA in and it works fine, and sometimes it acts as if the driver wasn’t installed. Any idea what could this be? Nevertheless is there somewhere I can download the driver to try and re-install it and see if this works things out? I Can’t find it on the cd and I dont wan’t to reinstall frontpanel everytime this problem occurs


Windows associates the XEM serial number with the driver and position on the bus. Sometimes, if you install a USB device on a different port, Windows will have you go through the driver installation process again.

See our “Software Downloads” forum to download the software. There is a Driver-Only install that is available for download. It is also on the CD.

It is likely, however, that this is a Windows issue and won’t be solved by a driver reinstall.

I suspect it’s related to vista, since this is the OS I’m using… regarding the port, I tried all of them but was unsuccessful… since I posted the last message, I found the driver on the CD but installing it again had no effect… It’s worth noting I have SP1 on my vista… also, when I first installed frontpanel, this issue didn’t arise. Now suddenly it did and I have no clue why.

@vitorbal-- We use Vista on a couple machines here. One is used extensively for development. Other machines are XP. We haven’t seen an issue with this on either Vista or XP and both have been updated to the latest service packs.

The driver configuration file (INF) is quite standard and simple, so I’m not sure why you are seeing issues. I know this is the last thing someone wants to hear, but it could just be that your Windows install has reached its “half life” and needs to be freshened.

You might want to try uninstalling the driver from the Device Manager. This may clear out enough of Vista’s memory of the driver to allow a fresh start.

Note that this is different than just uninstalling FrontPanel. By uninstalling the driver, you’re theoretically telling Windows to remove the INF and SYS files associated with the device.

As I was connecting and disconnecting the USB plug several times into different USB slots as usual to try and have the board recognized, something new came up. Suddenly the LED that indicates the board is ON wasn’t on anymore, and it seems like some parts of the board are heating more than they should. After disconnecting and reconnecting the power supply, the LED is still not working, and windows won’t recognize the board at all when I plug the USB in. I suspect something very bad might have happened to my board, and I have no idea why! Has this ever happened before? Is there anything I can do to identify the problem, i.e. something I can measure on the board, etc?

@vitorbal-- Please send an email to our support email.