DESTester.py python AttributeError

Hi I am a new to frontpanel and python and I am trying to test the pipein and pipout interfaces. I was able to do this with frontpanel but it is limited to pushbutton controlled read an write so I wanted to try python.

I installed python 2.4.1 from the opal kelly cd and I am running on windows 2000 I get the following error

IDLE 1.1.1 ==== No Subprocess ====

------ DES Encrypt/Decrypt Tester in Python ------
Traceback (most recent call last):
File “C:\Python24\OKpy\DESTester.py”, line 116, in ?
if (False == des.InitializeDevice()):
File “C:\Python24\OKpy\DESTester.py”, line 12, in InitializeDevice
if (self.xem.NoError != self.xem.OpenBySerial("")):
File “C:\Python24\lib\site-packages\ok\ok.py”, line 131, in
getattr = lambda self, name: _swig_getattr(self, FrontPanel, name)
File “C:\Python24\lib\site-packages\ok\ok.py”, line 21, in _swig_getattr
raise AttributeError,name
AttributeError: NoError

I don’t know where to go from here?

I also tried the precompiled c++ program DESTester.exe and it got further but failed configuring the fpga. I did copy the correct bit file to destop.bit

---- Opal Kelly ---- FPGA-DES Application v1.0 ----
FrontPanel DLL loaded. Built: Mar 10 2007 16:28:41
Found a device: XEM3010
Device firmware version: 3.0
Device serial number: cCZuOqzuju
Device device ID: Opal Kelly XEM3010
FPGA configuration failed.
FPGA could not be initialized.

I think the problem with the exe is that asyncronous transfers are enabled? I had to disable them in the frontpanel preferences to get it to configure the fpga.

Thanks

pixel-

It looks like the Python distributable is not correct. I’ll investigate soon. The C++ version of the DESTester (and all our samples) does not turn off asynchronous transfers. To disable, you’ll need to add the code and rebuild the samples from source.

I got our local C++ guru to help me recompile the program with the following line added right before downloading the fpga. Now it works fine.
dev->EnableAsynchronousTransfers(false);

Any idea how long it will take to get a solution for python?

Thanks

You can expect something today. It’s a relatively easy fix – I’m surprised this has gone unnoticed for so long.

Please see this post:

http://forums.opalkelly.com/showthread.php?p=1510