64-Bit SUSE Compatibility


#1

OK, So I’ve finally got FrontPanel to work in openSUSE 10.0, but is there a chance that your linux C++ libraries are only 32-bit? Do you have any 64-bit alternatives?

Regards,
Visionchip


#2

We do not currently do anything “special” to target 64-bit.

Are you having trouble running on a 64-bit machine? I thought all the OSes and chips would support 32-bit stuff just fine.


#3

It appears that the 32-bit library provided, won’t interface with other standard libraries.

My linker produces output warning me of incompatibility between i386 libraries (OpalKelly) and my i586 libraries (standard libraries bundled with 64-bit KDevelop).

My setup is an AMD Opteron 265 with openSUSE 10.0. It appears that I need quite a bit of 64-bit specific software. This was also the same when I ran FC4 & 5.

It is my understanding that 32-bit will run fine on 64-bit systems, but when you try to mix the two, problems start. This is why there are usually always 64-bit alternatives. I may be incredibly mistaken though.


#4

The best solution would be to compile the source for Frontpanel on your machine. I also have a 64-bit machine under FC5 and I would prefer to use this method. The official word on the source has ranged from “not anytime soon” to “not in the foreseeable future”. We could use an open source “backpanel.”


#5

This seems to be a good argument against compiling 32-bit libraries into 64-bit code.

http://www-128.ibm.com/developerworks/library/l-port64.html


#6

So in summary,

Would it be possible for you to compile your linux static lib in 64-bit mode? Or is it to be expected in the near future anyway?

Unfortunately, our project is using 7x XEM3001 with an opteron cluster, so it would be very much appreciated.

Regards
David


#7

Hi David-

I tried to contact one of your other team members, but haven’t heard from you. Please contact us at support@opalkelly.com and we’ll see what we can do for you.


#8

Hi Jake and All

We too are moving to Opteron based machines and are having some issues with the API. My problem is with Python. You provide headers and a compiles _ok.so. However this is a 32 bit library and python gives the following error message on an import ok command…

ImportError: /usr/lib64/python2.4/site-packages/ok/_ok.so: wrong ELF class: ELFCLASS32

There may be some way into making python happily use this .so but I am not sure how. Do you either have a workaround for this, a 64 bit version of this file or have a method to allow us to generate a new _ok.so?

Thanks

Stephen

Stephen


#9

Hi Stephen–

Unfortunately, it seems rather difficult (or at least unreliable) to build 64-bit applications from a 32-bit installation. Additionally, we do not have any 64-bit Linux hardware to test on, so we would be unable to verify anything.

So, at the moment, we can only say that we support 32-bit Linux.